37 messaggi dal 17 aprile 2017
Buonasera a tutti, sarà sicuramente una banalità la mia domanda, sto realizzando un sito in Visual Studio con pagine aspx.
Ho configurato in IIS il percorso per il sito.
Quando tento di aprire il sito mi da l'elenco dei file anzichè la pagina web.
Se faccio doppio click sulla pagina default.aspx mi dice errore 404 - pagina o directory non trovata.
Potete aiutarmi?
Vi ringrazio anticipatamente
28 messaggi dal 09 ottobre 2019
www.breveglieri.it
Joe01 ha scritto:

Ho configurato in IIS il percorso per il sito.
Quando tento di aprire il sito mi da l'elenco dei file anzichè la pagina web.
Se faccio doppio click sulla pagina default.aspx mi dice errore 404 - pagina o directory non trovata.
Potete aiutarmi?


Bisogna verificare come è stato configurato il sito.

Ad esempio, è stata creata la directory virtuale?
Se sì, è stata associata a un Application Pool appropriato?
L'Application Pool in questione ha il riferimento alla versione corretta del .NET Framework?

Mi insospettisce inoltre la frase "se faccio doppio click...": non c'è bisogno di cliccare da nessuna parte per aprire la pagina, ma è sufficiente visitare l'indirizzo corrispondente alla Web Application.

Farei un po' di verifiche e, nel caso, riporterei qui i parametri principali di configurazione impostati su IIS.

Ciao!

MARCO BREVEGLIERI
(Senior Software and Web Developer, Teacher and Consultant)
» Homepage: https://www.breveglieri.it
» Blog: https://www.compilaquindiva.com
» Podcast: https://www.delphipodcast.com
37 messaggi dal 17 aprile 2017
Mi insospettisce inoltre la frase "se faccio doppio click...": non c'è bisogno di cliccare da nessuna parte...

Lo so, ma era per spiegare



Ad esempio, è stata creata la directory virtuale? (Sì)


Se sì, è stata associata a un Application Pool appropriato?

L'Application Pool in questione ha il riferimento alla versione corretta del .NET Framework? Sto utilizzando Windowss Server 2016 il Net Framework dovrebbe essere 4.6

Io sto sviluppando con Visual Studio 2017 e il Framework della mia applicazione è il 4.6.2

Puoi darmi qualche informazione in più su cosa controllare esattamente?

Grazie
28 messaggi dal 09 ottobre 2019
www.breveglieri.it

Puoi darmi qualche informazione in più su cosa controllare esattamente?


Prova a dare un'occhiata cercando su Google: vi sono molteplici articoli che ne parlano.

Ad esempio, controlla la corrispondenza tra la tua configurazione e quella suggerita qui:
https://www.c-sharpcorner.com/article/asp-net-mvc5-deployment-on-windows-iis-server/
(ma si tratta solo di uno dei tanti esempi)

Le voci sono tante, quindi diventa difficile fare un elenco completo di tutte le cose da verificare: meglio partire dalla documentazione e, a mo' di checklist, verificare che tutte siano aderenti alle impostazioni suggerite.

Ciao!

MARCO BREVEGLIERI
(Senior Software and Web Developer, Teacher and Consultant)
» Homepage: https://www.breveglieri.it
» Blog: https://www.compilaquindiva.com
» Podcast: https://www.delphipodcast.com

Torna al forum | Feed RSS

ASPItalia.com non è responsabile per il contenuto dei messaggi presenti su questo servizio, non avendo nessun controllo sui messaggi postati nei propri forum, che rappresentano l'espressione del pensiero degli autori.