36 messaggi dal 13 marzo 2018
Buonasera,

ho creato un form dei contatti in una pagina web basato su System.Net.Mail; di seguito il codice
try
{
if (Page.IsValid)
{

MailMessage mailMessage = new MailMessage();
mailMessage.From = new MailAddress("indirizzo email");
mailMessage.To.Add("indirizzo e mail");
mailMessage.Subject = ""

mailMessage.Body = ""

mailMessage.IsBodyHtml = true;

SmtpClient smtpClient = new SmtpClient("smtp.gmail.com", 587);
smtpClient.EnableSsl = true;
smtpClient.Credentials = new
System.Net.NetworkCredential("indirizzo e mail", "password");
smtpClient.Send(mailMessage);

}


}

catch (Exception ex)
{
// Log the exception information to
// database table or event viewer
Label2.ForeColor = System.Drawing.Color.Red;
Label2.Text = "There is an unknown problem. Please try later";
}


Il form funziona perfettamente in locale, ma pubblicandolo (insieme al suo codice .cs) non mi arriva nessuna email. Ho provato a disattivare su gmail l'accessso di app meno sicure. in questo modo premendo il bottone di invio mi arriva una mail dicendomi che qualcuno ha tentato di accedere alla mia casella...Quindi il codice lo legge...non capisco dove possa essere il problema.

Suggerimenti?

Grazie
Ron
248 messaggi dal 08 gennaio 2011
Ciao, proprio ieri avevo lo steso problema. Mi pare di capire che se si usa come host un account Gmail è richiesta l'autenticazione del client quindi forse si deve usare un certificato; la classe smtpclient ha una proprietà ClientCertificates. Ma come fare non lo so.

Lo stesso codice da te postato non ha nessun problema e spedisce messaggi con allegati se uso come host un account di posta di un dominio acquistato su Aruba.

Se caso mai risolvi con Gmail ce lo fai sapere ?

Grazie.
Modificato da Mario Formosa il 12 gennaio 2020 10:15 -
248 messaggi dal 08 gennaio 2011
Ho scoperto che di default l'account google quindi anche gmail non consente l'accesso alle app meno sicure. Tuttavia questo blocco si può byapassare usando il seguente link e attivando l'accesso alle app meno sicure.

https://myaccount.google.com/lesssecureapps

Consentendo le app meno sicure, le mail vengono inviate, ma si rende l'account più vulnerabile.

Ciao.
36 messaggi dal 13 marzo 2018
Ciao, ti ringrazio della risposta...

disattivando l'accesso ad app meno sicuro su account google, mi arriva l'e mail che qualcuno ah tentato di accedere alla mia casella usando la mia email e password. mentre attivandolo non mi arriva nessuna mail inviata dal form...
in locale invece funziona perfettamente (mi arriva la mail compilando il form)...
ancora non sono riuscito a risolvere? suggerimenti?

grazie
Ron
36 messaggi dal 13 marzo 2018
Nonostante avessi permesso l'accesso ad app meno sicure, probabilmente google aveva qualche ulteriore misura di sicurezza.Sono andato qui
https://accounts.google.com/b/0/DisplayUnlockCaptcha

e ho abilitato l'accesso all'account. Sembra funzionare, quindi pare che il problema sia risolto.
Grazie a tutti comunque,

Ron
124 messaggi dal 01 febbraio 2017
Salve, dalle prove fatte, non è un problema di Flag "consenti APP meno sicure", e neanche di concedere l'accesso all'account, che hanno entrambi pesanti implicazioni sulla sicurezza dell'account Google. Devi semplicemente andare nella confifurazione di Google e dirgli quali solo le APP di terzi che sono abilitati ad accedere all'account Google qui : https://myaccount.google.com/permissions

Ciao.
Gino.
Modificato da SensoBit il 23 gennaio 2020 16:20 -

UNSTRING identifier-1 id-2 id-3
DELIMITED BY [ALL] OR [ALL] literal-1 lit-2
INTO {id-4 [DELIMITER IN id-5]
[COUNT IN id-6]}
[WITH POINTER id-7]
[TALLYING IN id-8]
[ON OVERFLOW imperative-statement-1]
[NOT ON OVERFLOW imper-2]
[END-UNSTRING]

Torna al forum | Feed RSS

ASPItalia.com non è responsabile per il contenuto dei messaggi presenti su questo servizio, non avendo nessun controllo sui messaggi postati nei propri forum, che rappresentano l'espressione del pensiero degli autori.