3.910 messaggi dal 28 gennaio 2003
con la porta 465, prova a usare la libreria AegisImplicitMail

Pietro
219 messaggi dal 20 novembre 2014
mexico77 ha scritto:
che eccezione ti da?


con la 25 da

System.Net.Mail.SmtpException: Errore durante l'invio della posta. ---> System.Net.WebException: Impossibile effettuare la connessione al server remoto. ---> System.Net.Sockets.SocketException: Impossibile stabilire la connessione. Rifiuto persistente del computer di destinazione 62.149.156.218:25
in System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
in System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket


mentre con la 465 (con questa il client di posta funziona)

System.Net.Mail.SmtpException: Timeout dell'operazione.
in System.Net.Mail.SmtpClient.Send(MailMessage message)
in ...
101 messaggi dal 30 novembre 2004
con la porta 465
modifica smtpClient.EnableSsl = false; a true
219 messaggi dal 20 novembre 2014
pietro09 ha scritto:
con la porta 465, prova a usare la libreria AegisImplicitMail


ho provato questa libreria, purtroppo nessun risultato, ho commentato tutto, sono giorni che ci sbatto di prove ne ho fatte parecchie
Grazie per averci provato :)
3.910 messaggi dal 28 gennaio 2003
Ebbene, anche noi abbiamo ARUBA.

la porta 25 ancora funziona, ma non la consigliano.
La porta 465 non funziona (posta aruba) col .net. Ma con la libreria indicata, a me funziona.

Pietro
219 messaggi dal 20 novembre 2014
mexico77 ha scritto:
con la porta 465
modifica smtpClient.EnableSsl = false; a true


Niente, sempre timeout, non so più cosa provare
219 messaggi dal 20 novembre 2014
pietro09 ha scritto:
Ebbene, anche noi abbiamo ARUBA.

la porta 25 ancora funziona, ma non la consigliano.
La porta 465 non funziona (posta aruba) col .net. Ma con la libreria indicata, a me funziona.


ma la 25 senza ssl? A me non funziona neanche la configurazione di outlook con la 25.
Questo è il codice fatto ieri con quella libreria

public void SendWithObjMultiToControllerCC(String to, String subj, String bodytext, Attachment obj)
{
///* codice per invio email 15/10/2014 */
MimeMailMessage msg = new MimeMailMessage();
string sendto = to.Trim();
string from = ConfigurationManager.AppSettings["From"];
string Pass = ConfigurationManager.AppSettings["Pass"];
var mailer = new MimeMailer("smtps.aruba.it", 465);
mailer.User = from;
mailer.Password = Pass;
mailer.SslType = SslMode.Ssl;
mailer.AuthenticationMode = AuthenticationType.Base64;
msg.From = new MailAddress(from);

//msg.To.Add(new MailAddress(sendto[i]));
//msg.CC.Add("a@b.c");
//if (!sendto.Trim().Equals(""))
//{
msg.Bcc.Add(new MailAddress(sendto));

msg.Subject = "test: " + subj;
msg.Body = bodytext + "<br><br><br> Questo messaggio è inviato automaticamente si prega di non rispondere!";
msg.IsBodyHtml = true;
//msg.Attachments.Add(obj);

mailer.SendMailAsync(msg);


//}



}

219 messaggi dal 20 novembre 2014
pietro09 ha scritto:
Ebbene, anche noi abbiamo ARUBA.

la porta 25 ancora funziona, ma non la consigliano.
La porta 465 non funziona (posta aruba) col .net. Ma con la libreria indicata, a me funziona.


Sono riuscito a fare andare la libreria finalmente... è già qualcosa, ma come c'è possibilità di allegare un file?
Grazie

Torna al forum | Feed RSS

ASPItalia.com non è responsabile per il contenuto dei messaggi presenti su questo servizio, non avendo nessun controllo sui messaggi postati nei propri forum, che rappresentano l'espressione del pensiero degli autori.