277 messaggi dal 03 ottobre 2006
Grazie Alessio, premesso che i FriendlyUrl li odio anch'io ma immagino sia perchè non ho ancora imparato ad usarli adeguatamente e quindi ad apprezzarne i vantaggi, ho fatto una prova e pare che partendo dal progetto originale di VisualStudio e aggiungendo il tuo codice qui sotto funzioni davvero tutto.
Perfino l'autenticazione "None" adesso funziona quindi ben venga la duplicazione delle due pagine nella location anche perchè saranno le uniche due con questa necessità.

Grazie
333 messaggi dal 05 novembre 2012
Ciao,

era solo una battuta...non odio le FriendlyUrl

è dal 2012 che non utilizzo webform per nuovi progetti...solo manutenzione...dal mio punto di vista (senza scendere nei dettagli) webform ha avuto i suoi momenti di gloria ma mvc è di gran lunga meglio

lavorando in webform, rispetto a mvc il concetto di routing è meno evidente e a riguardo FriendlyUrl fa un gran lavoro...non permette solo di omettere aspx nella url

In questo caso specifico bisognerebbe indagare e capire se il problema riguarda AspNet.FriendlyUrl o per esempio AspNet.Identity...se lo scopri facci sapere

/Ciao
Modificato da scioCoder il 28 febbraio 2019 10:19 -

Alessio
277 messaggi dal 03 ottobre 2006
Su questo argomento trovo sempre problemi nuovi... ora il mio cliente mi ha chiesto di avere una pagina di atterraggio index.html nella quale poi richiamare la mia applicazione.
Come si fa a rendere la pagina index.html di default quando si digita l'indirizzo principale ?
Tutti i suggerimenti del web sono falliti perchè comunque vada lui mi apre la pagina di login eppure index.html non ha un accesso proibito agli utenti non registrati perchè ho messo questo nel web.config:
<location path="Index.html">
<system.web>
<authorization>
<allow users="*"/>
</authorization>
</system.web>
</location>
<location path="Index">
<system.web>
<authorization>
<allow users="*"/>
</authorization>
</system.web>
</location>

e quindi se richiamo "nomesito/index.html" mi mostra tranquillamente la pagina
Invece digitando solo "nomesito" va sulla pagina di login
Nel pannello dell'hosting condiviso ho messo index.html in testa all'elenco delle pagine di default e ho messo anche questo nel file RouteConfig.cs
route.ignore("");
ma niente... continua a mostrarmi la pagina di login come se mantenesse l'idea di mostrami il default.aspx che in effetti è proibito ai non registrati
11.655 messaggi dal 09 febbraio 2002
Contributi
Ciao,
ok, se nulla funziona, prova con una regola di url rewring. Attenzione: funzionerà solo se il tuo hosting ha il modulo di URL Rewriting installato. È installato automaticamente in tutte le recenti versioni di IIS, quindi vale la pena provare.

All'interno del nodo system.webServer (non system.web) metti:
    <rewrite>
      <rules>
        <rule enabled="true" name="LandingPage">
          <match url="^/?$" />
          <action type="Rewrite" url="Index.html" />
        </rule>
      </rules>
    </rewrite>


ciao,
Moreno

Enjoy learning and just keep making
277 messaggi dal 03 ottobre 2006
uff... non funziona Moreno
<system.webServer>
<rewrite>
<rules>
<rule enabled="true" name="LandingPage">
<match url="^/?$" />
<action type="Rewrite" url="Index.html" />
</rule>
</rules>
</rewrite>
<handlers>
<add name="ELMAH" verb="POST,GET,HEAD" path="elmah.axd" type="Elmah.ErrorLogPageFactory, Elmah" preCondition="integratedMode" />
</handlers>
</system.webServer>

altre idee ?
potrei eliminare default.aspx come pagine accettate nell'elenco degli indirizzi del pannello di controllo dell'hosting ?
ho anche provato ma non mi lascia eliminare default.aspx :-(
Modificato da wmartin il 04 marzo 2019 21:42 -

c'è anche di peggio... mi manda si nella pagina di login, e solo dopo avermi accreditato mi mostra index.html !!
Modificato da wmartin il 04 marzo 2019 23:21 -
11.655 messaggi dal 09 febbraio 2002
Contributi

uff... non funziona Moreno

Vuoi dire che il modulo di url rewriting non è installato? A me in locale la regola di riscrittura funziona...
Che versione di Windows Server hai con l'hosting?


ho anche provato ma non mi lascia eliminare default.aspx :-(

Questa impostazione la puoi fare anche dal web.config, infatti IIS può essere configurato dal nodo system.webServer.

    <defaultDocument enabled="true">
      <files>
        <clear />
        <add value="Index.html"/>
      </files>
    </defaultDocument>

Enjoy learning and just keep making
277 messaggi dal 03 ottobre 2006
Non chiedermi perchè ma sembra che la combinazione di queste due cose

<rewrite>
<rules>
<rule enabled="true" name="LandingPage">
<match url="^/?$" />
<action type="Rewrite" url="index.html" />
</rule>
</rules>
</rewrite>
<defaultDocument enabled="true">
<files>
<clear />
<add value="Index.html"/>
</files>
</defaultDocument>

abbia risolto il problema.
Singolarmente non bastano
Grazie
11.655 messaggi dal 09 febbraio 2002
Contributi
Ok, meno male, buono a sapersi :)

Enjoy learning and just keep making

Torna al forum | Feed RSS

ASPItalia.com non è responsabile per il contenuto dei messaggi presenti su questo servizio, non avendo nessun controllo sui messaggi postati nei propri forum, che rappresentano l'espressione del pensiero degli autori.