875 messaggi dal 11 febbraio 2013
Ciao,
in un controller non riesco a fare l'upload in produzione (in development nessun errore)

Impossibile visualizzare la pagina perché l'entità della richiesta è troppo grande.

Nell'action del controller ho impostato

[RequestSizeLimit(1000000000)]

in program.cs

public static IWebHostBuilder CreateWebHostBuilder(string[] args) =>
           WebHost.CreateDefaultBuilder(args)
               .UseStartup<Startup>()
               .UseSerilog((webHostBuilderContext, loggerConfiguration) => 
                {
                    loggerConfiguration.ReadFrom.Configuration(webHostBuilderContext.Configuration);
                })
               .UseKestrel(options=>{
                   options.Limits.MaxRequestBodySize =long.MaxValue;
               });


In IIS
system.webServer/serverRuntime > uploadReadAheadSize 2147483647

almeno questo è quello che ho trovato in rete

grazie
875 messaggi dal 11 febbraio 2013
Ho risolto impostando la lunghezza massima consentita del filtro su gestione IIS

ciao

Torna al forum | Feed RSS

ASPItalia.com non è responsabile per il contenuto dei messaggi presenti su questo servizio, non avendo nessun controllo sui messaggi postati nei propri forum, che rappresentano l'espressione del pensiero degli autori.