377 messaggi dal 08 settembre 2001
ciao,

ho messo online una parte del sito, in locale funziona perfettamente mentre online non va. I file che ho messo online l'ho presi tramite il metodo Copy File di VS, perciò sicuramente non ho dimenticato nulla.

Questo è il codice:

code:--------------------------------------------------------------------------------
Sub Login(ByVal sender As Object, ByVal e As System.EventArgs)
dim ObjDatabase as new TYASPNET.database()

ObjDatabase.ConnectionString = "provider=Microsoft.Jet.OLEDB.4.0; data source=" & Server.MapPath("../mdb-database/fg-tunisie.mdb")

Dim objReader As OleDbDataReader

objReader = objDatabase.SelectSQL("SELECT id FROM Admin WHERE Nome='"& ObjDatabase.Controlla_Stringa(Nome.text) &"' AND Pwd='"& ObjDatabase.Controlla_Stringa(Pwd.Text) &"' ")

if not objReader is nothing then
Session("Admin")="ok"
objReader.Close
response.redirect ("index.aspx")
else
Errore.Visible = True
Errore.Text = "ERRORE"
end if

End Sub
--------------------------------------------------------------------------------


vado sempre nella parte ELSE come mai? da cosa può dipendere?

ripeto che il db è pieno e in locale funziona perfettamente.
mancanza di permessi per l'utente nomecomputer\ASPNET

Daniele Bochicchio | ASPItalia.com | Libri
Chief Digital Officer@icubed | Chief Innovation Officer@openloop
Microsoft Regional Director, MV
377 messaggi dal 08 settembre 2001
quando provo ad inserire o a modificare un record ricevo questo:

Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>



anceh questo dipende da un problema di permessi settati sull'utente ASP_NET?

questo dipende dal fatto che non hai abilitato la visualizzazione degli errori. aggiungi quel codice che ti suggerisce nel file web.config e vedrai la rela causa dell'errore.

Daniele Bochicchio | ASPItalia.com | Libri
Chief Digital Officer@icubed | Chief Innovation Officer@openloop
Microsoft Regional Director, MV
38 messaggi dal 06 giugno 2002
come aggiungi ? (ho pure io lo stesso identico problema, avendo appena aggiornato sulla macchina dove pubblico il framew. alla versione 1.1 )

non mi funziona ne se gli metto questo
<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>


ne se gli metto questo
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>

Torna al forum | Feed RSS

ASPItalia.com non è responsabile per il contenuto dei messaggi presenti su questo servizio, non avendo nessun controllo sui messaggi postati nei propri forum, che rappresentano l'espressione del pensiero degli autori.