2 messaggi dal 03 dicembre 2018
Salve a tutti .

Nell'azienda dove lavoro a suon di scarica barile mi è arrivato da risolvere un quesito apparentemente semplice ma che per me non essendo propriamente del campo , impossibile da risolvere.

Ho un server Microsoft-IIS/10.0 ,x-aspnetmvc-version5.2, x-aspnet-version4.0.30319,

Automaticamente ASP inserisce l'xframe su SAMEORIGIN di default .
Intervenendo sul server posso aggiungere l'opzione allow , con risultato che facendo il check con i vari tool ho sia SAMEORIGIN che ALLOW nell'xframe.

Sono settimane che mi documento ma non riesco a risolvere .
Attualmente il mio server non ha il file Global.asax.cs ma ha soltanto il Global.asax al cui interno ho soltanto questa stringa

<%@ Application Codebehind="Global.asax.cs" Inherits="NetBrain.MvcApplication" Language="C#"%>


Non ho proprio idea di come indentare e di come mettere questa che probabilmente è la soluzione trovata in rete.
"
I had created an application that was meant to be displayed in a frame loaded from another url. There were issues with the frame not loading properly and using developer tools the console displayed the error:

Refused to display '...' in a frame because it set 'X-Frame-Options' to 'SAMEORIGIN'

The fix to this was to add :

AntiForgeryConfig.SuppressXFrameOptionsHeader = true;

to the Application_Start function in Global.asax. You must also add:

using System.Web.Helpers;

to get access to that."


Vi ringrazio in modo anticipato e spero che qualche anima pia mi riesca a dare qualche consiglio su come risolvere evitando di farmi saltare col tritolo sul server nella sede principale .

Grazie a tutti e buona serata

Torna al forum | Feed RSS

ASPItalia.com non è responsabile per il contenuto dei messaggi presenti su questo servizio, non avendo nessun controllo sui messaggi postati nei propri forum, che rappresentano l'espressione del pensiero degli autori.