Salve, utilizzando Visual Studio Community 2017, ho creato un nuovo progetto selezionando "Applicazione Web ASP.NET (.NET Framework) -> Web Form (Modifica autenticazione=Account utente individuali).
Ho settato SQL locale e tutto mi funziona. Il problema sta nel momento in cui pubblico il progetto (setto web.config puntando a db SQL di Aruba) e mi da l'errore "Server Error in '/' Application". Non riesco a capire dove/cosa sbaglio.
Grazie!
Fabio
10.265 messaggi dal 09 febbraio 2002
Contributi
Ciao Fabio,
quella che stai vedendo è una pagina di cortesia che serve a notificare ai visitatori che si è verificato un problema senza però rivelare qual è la sua vera causa.

Bisogna rimuoverla da web.config, creando un nodo customErrors in system.web ed impostato il suo attributo mode su Off.
Lo trovi indicato qui:
http://forum.aspitalia.com/forum/post/415625/Accesso-A-Database.aspx#415643

Dopo aver fatto questo cambiamento, aggiorna la pagina e posta il testo dell'errore che appare.

ciao,
Moreno

Enjoy learning and just keep making
Ciao, questo l'errore:

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: The 'tempDirectory' attribute must be set to a valid absolute path.

Source Error:

An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Source File: C:\Windows\Microsoft.NET\Framework\v4.0.30319\Config\web.config Line: 804
10.265 messaggi dal 09 febbraio 2002
Contributi
Ciao,
prova a togliere l'attributo tempDirectory alla riga 804 del web.config, vediamo se si risolve.
L'avevi impostato tu manualmente? Se ne hai bisogno durante lo sviluppo dell'applicazione ma lo vuoi rimuovere quando vai in produzione, allora usa le web.config transformations.

Probabilmente sull'attributo tempDirectory è impostato il percorso di una cartella che esiste sul tuo PC di sviluppo ma non sul server.

ciao,
Moreno

Enjoy learning and just keep making
Ciao Moreno,
non capisco dove cercare perchè nel Web.config non ho una riga 804 e non ho tempDirectory.
Il mio Web.config arriva a 51 righe
10.265 messaggi dal 09 febbraio 2002
Contributi
Ciao,


non capisco dove cercare perchè nel Web.config non ho una riga 804 e non ho tempDirectory.

sì, giusto, ora che ci faccio caso, il web.config a cui fa riferimento l'errore è quello di root, infatti il suo percorso è:

C:\Windows\Microsoft.NET\Framework\v4.0.30319\Config\web.config


L'errore lo hai anche se pubblichi una singola pagina Default.aspx, senza neanche un web.config?
In caso prova a chiedere assistenza ad Aruba, magari c'è un loro errore di configurazione per quel particolare server.

ciao,
Moreno

Enjoy learning and just keep making
Ciao Moreno,
mi sa che è un loro (Aruba) il problema. Ho già inoltrato il ticket ad Aruba.

Grazie mille per l'aiuto

Buona giornata
Fabio

Torna al forum | Feed RSS

ASPItalia.com non è responsabile per il contenuto dei messaggi presenti su questo servizio, non avendo nessun controllo sui messaggi postati nei propri forum, che rappresentano l'espressione del pensiero degli autori.