38 messaggi dal 04 marzo 2012
Quello che viene passato è riferito a dei filtri che è possibile fare sull'estrazione dei dati, adesso sono vuoti perchè non ne ho impostati.
Luigi
10.246 messaggi dal 09 febbraio 2002
Contributi
Ciao,
proviamo a vedere se la causa può essere il Response.Redirect che si trova a riga 20.

Response.Redirect(MM_authFailedURL)

Prova a cambiarlo: per il momento trasformalo in un Response.Write, così che il percorso ti venga visualizzato a schermo.


Response.Write(MM_authFailedURL)


Riesci a vedere il percorso a schermo? Ti sembra corretto?
Vedo che questa ridirezione punta ad un file ../noaccess.asp. Il file esiste? Si trova effettivamente una directory più su rispetto alla posizione di analisiexcel.asp?


Se non riesci a vedere il percorso a schermo, probabilmente allora il problema è da qualche altra parte. Hai abilitato il debugging per le pagine in ASP classico, per capire come viene eseguita la pagina?

ciao,
Moreno

Enjoy learning and just keep making
38 messaggi dal 04 marzo 2012
Scusate il ritardo nella risposta, allora ho provato a mettere il response.write non il problema non cambia mi viene sempre dato l'errore della pagina non trovata.

HO verificato nuovamente l'indirizzo della pagina che vedo è ed corretta, la pagina c'è.
Ho verificato anche la presenza della pagina noaccess.asp ed anche questa è presente.

HO fatto altre prove, se metto un filtro in più oltre alla data, ed allora il problema non accade si apre excel e ci scrive dentro qualcosa che poi sia sbagliato perchè mi viene dato errore di formula circolare e non riempie i dati ma solo le testate, penso sia un altro problema da affrontare in un secondo momento.

A questo punto non riesco a capire cosa possa essere, provo a indicare la stringa che vedo a video:
http://analisimargine/pagliara/analisiexcel.asp?DAL=01%2F01%2F17&AL=30%2F06%2F17&ART1=&ART2=&GM1=&GM2=&GM3=&GM4=&CTY=T&MAG=&MAGE=&AG1=&AG2=&MA1=&MA2=&MA3=&MA4=

Per quanto riguarda il debug, come faccio a mettere quello Classico di ASP?
Ringrazio anticpatamente.
Luigi
10.246 messaggi dal 09 febbraio 2002
Contributi
Ciao,

segui questa guida per abilitare il debug di asp classico.
https://weblogs.asp.net/dixin/debugging-classic-asp-with-visual-studio

Dato che la pagina è lunga, provare a debuggarla con Visual Studio sarà l'approccio più veloce.

ciao,
Moreno

Enjoy learning and just keep making

Torna al forum | Feed RSS

ASPItalia.com non è responsabile per il contenuto dei messaggi presenti su questo servizio, non avendo nessun controllo sui messaggi postati nei propri forum, che rappresentano l'espressione del pensiero degli autori.