422 messaggi dal 11 febbraio 2013
Ciao a tutti
non capisco perchè non vedo la finestra modale del messaggio di attesa sul tablet
della mia web app

 #modal {
            display: none;
            width: 100%;
            height: 100%;
            position: fixed;
            top: 0;
            left: 0;
            overflow: hidden;
            background-color: rgb(0,0,0);
            opacity: 0.5;
            z-index:1000; 
                     
        }

 #modal-content{
            position:relative;
            width:100px;
            height:100px;
            top:50%;
            left:50%;
            margin-left: -50px;
            margin-top: -50px;
        } 

 <div id="modal">
        <div id="modal-content">
            <img src="~/Images/Loading.gif" style="width:97px;height:97px;border: solid 3px blue;border-radius:3px;" />
        </div>
    </div>


Il codice è molto semplice e funziona su altri dispositivi
10.227 messaggi dal 09 febbraio 2002
Contributi
Ciao,
prova a semplificare ulteriormente il tuo codice. E' possibile che Safari non digerisca qualcosa, tipo i margini negativi.

Dato che devi centrare un'immagine sia orizzontalmente che verticalmente, la cosa più supportata e facile da fare è posizionarla come sfondo del suo contenitore. Ecco un esempio di codice CSS che non richiede la presenza di un elemento modal-content:
#modal {
  background-color: rgba(0,0,0,0.5);
  background-image: url('http://i.stack.imgur.com/MnyxU.gif');
  background-position: center center;
  background-repeat: no-repeat;
  position:fixed;
  top:0;
  left:0;
  width:100%;
  height:100%;
}

Così semplifichi sia il markup che gli stili.

Lo vedi qui in movimento:
https://jsfiddle.net/32LLhpcy/

ciao,
Moreno
Modificato da BrightSoul il 16 luglio 2017 22.36 -

Enjoy learning and just keep making
422 messaggi dal 11 febbraio 2013
Ciao Moreno

intanto grazie perchè il codice si è dimezzato

tuttavia sul tablet non vedo il div...

cosa posso provare ?

ciao !!!
Modificato da jjchuck il 17 luglio 2017 10.50 -
422 messaggi dal 11 febbraio 2013
ho risolto con un image dentro al div

non ho saputo fare di meglio

ciao

Torna al forum | Feed RSS

ASPItalia.com non è responsabile per il contenuto dei messaggi presenti su questo servizio, non avendo nessun controllo sui messaggi postati nei propri forum, che rappresentano l'espressione del pensiero degli autori.