162 messaggi dal 10 aprile 2001
Buongiorno.
Aprendo una pagina .aspx in un popup...

<img src="/images/Nuevo.gif" border="0" onclick="javascript:window.open('NuovoHW.aspx', 'reg','width=400,height=225,left=270,top=180')" />

...mi vengono richieste le credenziali, le quali oltretutto non vanno bene.
Premetto che sono su un server Windows 2012 in IIS ovviamente e SQL Server Express. Il tutto è configurato per l'autenticazione di dominio (e funziona correttamente), ma all'esecuzione del suddetto codice appare la richiesta di credenziali (Windows) e stop.

Il problema sembra nella pagina che si apre nel popup:

<%@ Page Language="VB" AutoEventWireup="false" CodeFile="NuovoHW.aspx.vb" Inherits="NuovoHW" %>
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<title>New HW</title>
</head>
<body>
<form id="form1" runat="server">
<asp:SqlDataSource ID="SqlDataSourceNuovoHW" runat="server" ConnectionString="<%$ ConnectionStrings:ICString %>" InsertCommand="INSERT INTO [Hardware] ([NomeHardware], [Categoria], [Note]) VALUES (@NomeHardware, @Categoria, @Note)" SelectCommand="SELECT Categoria FROM Hardware GROUP BY Categoria">
<InsertParameters>
<asp:ControlParameter Name="NomeHardware" ControlID="NomeHardware" PropertyName="text" />
<asp:ControlParameter Name="Categoria" ControlID="DDLCategoria" PropertyName="SelectedValue" />
<asp:ControlParameter Name="Note" ControlID="Note" PropertyName="Text" />
</InsertParameters>
</asp:SqlDataSource>


<asp:Table ID="Table1" runat="server" BackColor="Gray">
<asp:TableRow>
<asp:TableCell ColumnSpan="2" HorizontalAlign="Center"><strong>INSERIMENTO NUOVO HARDWARE</strong></asp:TableCell></asp:TableRow>
<asp:TableRow>
<asp:TableCell>Nome componente</asp:TableCell><asp:TableCell>
<asp:TextBox ID="NomeHardware" MaxLength="30" size="35" runat="server" /></asp:TableCell></asp:TableRow>
<asp:TableRow>
<asp:TableCell>Categoria</asp:TableCell><asp:TableCell>
<asp:DropDownList ID="DDLCategoria" runat="server" DataSourceID="SqlDataSourceNuovoHW" DataTextField="Categoria" DataValueField="Categoria"></asp:DropDownList>
<a href="newCategoria.asp?HW=1">
<img src="/images/Nuevo.gif" border="0"></a>
</asp:TableCell>
</asp:TableRow>
<asp:TableRow>
<asp:TableCell>Note</asp:TableCell><asp:TableCell>
<asp:TextBox ID="Note" MaxLength="30" size="35" runat="server" /></asp:TableCell></asp:TableRow>
<asp:TableRow>
<asp:TableCell ColumnSpan="2" HorizontalAlign="right"><input type="submit" value="Salva" runat ="server" ></asp:TableCell></asp:TableRow>
</asp:Table>
</form>
</body>
</html>

Roberto
Modificato da robycave il 21 marzo 2017 11.56 -
Modificato da robycave il 21 marzo 2017 11.56 -
162 messaggi dal 10 aprile 2001
La colpa è qui:

<a href="newCategoria.asp?HW=1"><img src="/images/Nuevo.gif" border="0"></a>


Roberto
Le pagine hanno tutti gli stessi permessi?
Tasto destro sul file> Proprietà> Sicurezza

Se l'applicativo funziona tutto sullo stesso database, immagino che non sia un problema di database visto che la pagina su cui stai lavorando funziona correttamente

Ormai programmano tutti... ma la professionalità appartiene a pochi

Torna al forum | Feed RSS

ASPItalia.com non è responsabile per il contenuto dei messaggi presenti su questo servizio, non avendo nessun controllo sui messaggi postati nei propri forum, che rappresentano l'espressione del pensiero degli autori.