11.097 messaggi dal 09 febbraio 2002
Contributi
Ciao,


Si utilizzo i pacchetti nuget, e diversamente non saprei come fare

No no, il problema non è usare NuGet, che è "solo" un modo per distribuire delle librerie e dei tool. Il problema potrebbe essere in una di quelle librerie, nel caso in cui richieda il full trust. Non ti so dire quale perché non conosco cosa fa la tua applicazione. Per farti un esempio, se stai usando SignalR che è una libreria per realizzare applicazioni realtime, sul medium trust non riuscirai a farla funzionare.

In caso posta il contenuto del tuo file packages.config così vediamo se stai usando pacchetti NuGet che richiedono il full trust.


Ecco il mio web.config. prima di conoscere questo sito, avevo intuito che tutto il problema gira intorno a questo benedetto file

Sì, dunque, nel web.confg puoi avere un riferimento ad elementi che richiedono il full trust, come il compilatore Roslyn che si era discusso in questo thread. Escluso quello, l'applicazione è tornata a funzionare.

Per come è messo il tuo web.config adesso, non c'è nulla che richieda il full trust perché hai commentato quasi tutto (troppo). Prova ad escludere giusto Roslyn e l'ApplicationInsightsWebTracking. L'elemento connectionStrings lo devi aggiornare secondo i dati di connessione al database Sql Server che Aruba deve averti mandato.

<?xml version="1.0" encoding="utf-8"?>
<!--
  Per altre informazioni sulla configurazione dell'applicazione ASP.NET, visitare
  http://go.microsoft.com/fwlink/?LinkId=301880
  -->
<configuration>
  <configSections>
    <!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 -->
    <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
  </configSections>
  <appSettings>
    <add key="webpages:Version" value="3.0.0.0" />
    <add key="webpages:Enabled" value="false" />
    <add key="ClientValidationEnabled" value="true" />
    <add key="UnobtrusiveJavaScriptEnable  " value="true" />
  </appSettings>

 
  <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Helpers" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="3.0.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.WebPages" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="3.0.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="1.0.0.0-5.2.3.0" newVersion="5.2.3.0" />
      </dependentAssembly>
    </assemblyBinding>
  </runtime>
  
  <!--
  <system.codedom>
    <compilers>
      <compiler language="c#;cs;csharp" extension=".cs" type="Microsoft.CodeDom.Providers.DotNetCompilerPlatform.CSharpCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" warningLevel="4" compilerOptions="/langversion:6 /nowarn:1659;1699;1701" />
      <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" type="Microsoft.CodeDom.Providers.DotNetCompilerPlatform.VBCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" warningLevel="4" compilerOptions="/langversion:14 /nowarn:41008 /define:_MYTYPE=\"Web\" /optionInfer+" />
    </compilers>
  </system.codedom>
  -->

<entityFramework>
    <defaultConnectionFactory type="System.Data.Entity.Infrastructure.LocalDbConnectionFactory, EntityFramework">
      <parameters>
        <parameter value="mssqllocaldb" />
      </parameters>
    </defaultConnectionFactory>
    <providers>
      <provider invariantName="System.Data.SqlClient" type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer" />
    </providers>
  </entityFramework>
  
  
  <connectionStrings>
  <!--
  <add name="NomeTuaConnectionString"
    connectionString="metadata=res://*/Models.Model1.csdl|res://*/Models.Model1.ssdl|res://*/Models.Model1.msl;provider=System.Data.SqlClient;provider connection string="data source=(LocalDB)\MSSQLLocalDB;attachdbfilename=|DataDirectory|\Database1.mdf;integrated security=True;MultipleActiveResultSets=True;App=EntityFramework"" providerName="System.Data.EntityClient" />
  -->
  </connectionStrings>
  
  
  <!-- PER L ' EMAIL !!!!!!!!!!!!!!!!!!!!!!-->

<system.net>
   <mailSettings>
    <smtp from="you@outlook.com">
      <network host="smtp-mail.outlook.com" 
               port="587" 
               userName="XXX"
               password="XXX" 
               enableSsl="true" />
    </smtp>
  </mailSettings>

</system.net>
  </configuration>



Poi...

Attualmente il sito mostra la home ma non riesco a far funzionare niente altro

Beh, se non altro la home funziona, quindi il problema dev'essere in qualche funzionalità che usi negli altri controller o nelle altre action dell'HomeController. Cerca di capire quali sono le funzionalità responsabili.



Esiste un modo per ricevere una notifica ad ogni risposta su questo post?

Sì, c'è una checkbox "Notifica risposte" su in alto, nei pressi del titolo del thread.


ciao,
Moreno

Enjoy learning and just keep making
9 messaggi dal 18 gennaio 2017
Buongiorno a tutti eccomi ritornato!

subito come richiesto ecco il package.config

<?xml version="1.0" encoding="utf-8"?>
<packages>
  <package id="bootstrap" version="3.0.0" targetFramework="net452" />
  <package id="EntityFramework" version="6.1.3" targetFramework="net452" />
  <package id="EntityFramework.it" version="6.1.3" targetFramework="net452" />
  <package id="jQuery" version="1.10.2" targetFramework="net452" />
  <package id="Microsoft.AspNet.Mvc" version="5.2.3" targetFramework="net452" />
  <package id="Microsoft.AspNet.Mvc.it" version="5.2.3" targetFramework="net452" />
  <package id="Microsoft.AspNet.Razor" version="3.2.3" targetFramework="net452" />
  <package id="Microsoft.AspNet.Razor.it" version="3.2.3" targetFramework="net452" />
  <package id="Microsoft.AspNet.WebPages" version="3.2.3" targetFramework="net452" />
  <package id="Microsoft.AspNet.WebPages.it" version="3.2.3" targetFramework="net452" />
  <package id="Microsoft.CodeDom.Providers.DotNetCompilerPlatform" version="1.0.0" targetFramework="net452" />
  <package id="Microsoft.Net.Compilers" version="1.0.0" targetFramework="net452" developmentDependency="true" />
  <package id="Microsoft.Web.Infrastructure" version="1.0.0.0" targetFramework="net452" />
  <package id="Modernizr" version="2.6.2" targetFramework="net452" />
  <package id="SimpleCrypto" version="0.3.30.26" targetFramework="net452" />
</packages>



La mia Home non "funziona", mi sono spiegato male. In realta' riesco a visualizzare la home ma nulla di tutto il resto .


I miei dati sql sono simili a questi
Host DataBase: 62.149.153.58
Nome DataBase: MSSql123456
Login DataBase: MSSql123456
PassWord DataBase: 1234567890




Stavo proprio per pensare a come cambiare la stringa di connessione al Db, ma non sono riuscito a trovare una guida.

<add name="NomeTuaConnectionString"
    connectionString="metadata=res://*/Models.Model1.csdl|res://*/Models.Model1.ssdl|res://*/Models.Model1.msl;provider=System.Data.SqlClient;provider connection string="data source=(LocalDB)\MSSQLLocalDB;attachdbfilename=|DataDirectory|\Database1.mdf;integrated security=True;MultipleActiveResultSets=True;App=EntityFramework"" providerName="System.Data.EntityClient" />
  


Buona Giornata,
Giovanni!
11.097 messaggi dal 09 febbraio 2002
Contributi
Ciao Giovanni,
dal packages.json risultano i riferimenti ai pacchetti di Roslyn.
Microsoft.CodeDom.Providers.DotNetCompilerPlatform
Microsoft.Net.Compilers


Questi vanno rimossi, quindi usa l'interfaccia grafica di NuGet per disinstallarli: tasto destro sulle "References" del progetto -> Gestisci pacchetti Nuget -> clicca la X rossa per rimuovere i due pacchetti.

Inoltre c'è un pacchetto SimpleCrypto che non so se richieda il full trust o meno, non l'ho mai usato.

Elimina i file dal tuo spazio web prima di ripubblicare l'applicazione, altrimenti rischi che nella cartella bin restino gli assembly che hai rimosso.

Ricordati di commentare/eliminare il nodo system.codeDom dal web.config, nel caso tu non l'abbia già fatto.



La mia Home non "funziona"
[...]
riesco a visualizzare la home

Posta uno screenshot che non ho capito se funziona o no :)
Se la home si carica senza errori lato server, per me "funziona". Poi, se è tutto spaginato, se mancano css o immagini, allora quello è un altro problema. Ma se tu dal browser riesci a vedere il sorgente HTML della pagina generata dal tuo HomeController, allora possiamo dire che "funziona".
Se è effettivamente spaginata, potrebbe dipendere dai bundle ed un possibile workaround è questo.


ciao,
Moreno

Enjoy learning and just keep making
9 messaggi dal 18 gennaio 2017
Buongiorno a tutti,

Grazie Moreno, Finalmente i primi risultati. Ho effettuato sotto il consiglio di Moreno, qualche modifica al mio web.config. ORA funziona tutto! sono felicissimo grazie a tutti per l'aiuto :)



<?xml version="1.0" encoding="utf-8"?>

    <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
  </configSections>
  <appSettings>
    <add key="webpages:Version" value="3.0.0.0" />
    <add key="webpages:Enabled" value="false" />
    <add key="ClientValidationEnabled" value="true" />
    <add key="UnobtrusiveJavaScriptEnable  " value="true" />
  </appSettings>



<location allowOverride="false">
 <system.web>
 

      <authentication mode="Forms">
        <forms loginUrl="/Login/Index" timeout="60" > </forms>
      </authentication>


      <customErrors mode="Off">
      </customErrors>




    </system.web>
  </location>



<entityFramework>
    <defaultConnectionFactory type="System.Data.Entity.Infrastructure.LocalDbConnectionFactory, EntityFramework">
      <parameters>
        <parameter value="mssqllocaldb" />
      </parameters>
    </defaultConnectionFactory>
    <providers>
      <provider invariantName="System.Data.SqlClient" type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer" />
    </providers>
  </entityFramework> 
  
  

<connectionStrings>
  <add name="DatabaseContext" connectionString="metadata=res://*/Models.Model1.csdl|res://*/Models.Model1.ssdl|res://*/Models.Model1.msl;provider=System.Data.SqlClient;provider connection string="Data Source=62.149.153.58;Initial catalog=MSSql123456;User Id=MSSql123456;Password=tuapassword;MultipleActiveResultSets=True;App=EntityFramework"" providerName="System.Data.EntityClient" />
</connectionStrings>
  


</system.net>
  </configuration>
11.097 messaggi dal 09 febbraio 2002
Contributi
Ceeeee-lebration!
Bravo per non aver desistito subito :)

Enjoy learning and just keep making
1 messaggio dal 29 novembre 2018
Buonasera,

Ho un problema simile, devo collegarmi ad un servizio su hosting aruba in medium trust, secondo la documentazione miscrostoft(https://docs.microsoft.com/en-us/dotnet/framework/wcf/feature-details/partial-trust-feature-compatibility) è possibile solo attraverso i binding BasicHttpBinding e WebHttpBinding, e con WSHttpBinding solo impostando security mode su transport, piu in basso riporta anche :

"Unsupported Bindings
Bindings that use reliable messaging, transactions, or message-level security are not supported."

Ho necessita di utilizzare il WSHttpBinding per via che supporta le transazioni, se è presente almeno un metodo con TransactionFlowOption.Mandatory il WSHttpBinding non è supportato in medium trust?

Con questa configurazione del web config sul server non ricevo risposta quando richiamo un metodo del servizio, nessuna risposta fino al termine del timeout impostato a 1 minuto, aumentando il timeout il problema resta.

Grazie
Davide


Web config sul server:

<system.serviceModel>
<protocolMapping>
<add scheme="https" binding="wsHttpBinding" />
</protocolMapping>
<serviceHostingEnvironment multipleSiteBindingsEnabled="true"/>
<services>
<service name="WcfBunnyManager.Service1" behaviorConfiguration="WcfBunnyManagerBehavior">
<host>
<baseAddresses>
<add baseAddress="http://localhost:8733/Design_Time_Addresses/WcfBunnyManager/Service1/"/>
</baseAddresses>
</host>
<!-- Service Endpoints -->
<!-- Se non è completamente qualificato, l'indirizzo è relativo all'indirizzo di base fornito sopra -->
<endpoint address="" binding="basicHttpBinding" contract="WcfBunnyManager.IService1">
<!--
Durante la distribuzione è necessario rimuovere o sostituire il seguente elemento Identity per riflettere
l'identità con cui viene eseguito il servizio distribuito. Se rimosso, WCF dedurrà automaticamente un'identità
appropriata.
-->
<identity>
<dns value="localhost"/>
</identity>
</endpoint>
<!-- Metadata Endpoints -->
<!-- L'endpoint di scambio metadati viene utilizzato dal servizio per offrire una migliore visualizzazione ai client. -->
<!-- L'endpoint non utilizza un'associazione protetta e deve essere protetto o rimosso prima della distribuzione -->
<!--<endpoint address="mex" binding="mexHttpBinding" contract="IMetadataExchange"/>-->
</service>
<service name="WcfBunnyManager.Avviso" behaviorConfiguration="WcfBunnyManagerBehavior">
<host>
<baseAddresses>
<add baseAddress="http://localhost:8733/Design_Time_Addresses/WcfBunnyManager/Avviso/"/>
</baseAddresses>
</host>
<!-- Service Endpoints -->
<!-- Se non è completamente qualificato, l'indirizzo è relativo all'indirizzo di base fornito sopra -->
<endpoint address="" binding="basicHttpBinding" contract="WcfBunnyManager.IAvviso">
<!--
Durante la distribuzione è necessario rimuovere o sostituire il seguente elemento Identity per riflettere
l'identità con cui viene eseguito il servizio distribuito. Se rimosso, WCF dedurrà automaticamente un'identità
appropriata.
-->
<identity>
<dns value="localhost"/>
</identity>
</endpoint>
<!-- Metadata Endpoints -->
<!-- L'endpoint di scambio metadati viene utilizzato dal servizio per offrire una migliore visualizzazione ai client. -->
<!-- L'endpoint non utilizza un'associazione protetta e deve essere protetto o rimosso prima della distribuzione -->
<!--<endpoint address="mex" binding="mexHttpBinding" contract="IMetadataExchange"/>-->
</service>
<service name="WcfBunnyManager.DataLayer" behaviorConfiguration="WcfBunnyManagerBehavior">
<host>
<baseAddresses>
<add baseAddress="http://localhost:8733/Design_Time_Addresses/WcfBunnyManager/DataLayer/"/>
</baseAddresses>
</host>
<!-- Service Endpoints -->
<!-- Se non è completamente qualificato, l'indirizzo è relativo all'indirizzo di base fornito sopra -->
<endpoint address="" binding="wsHttpBinding" bindingConfiguration="WSHttpBinding_IDataLayer" contract="WcfBunnyManager.IDataLayer" name="WSHttpBinding_IDataLayer">
<!--
Durante la distribuzione è necessario rimuovere o sostituire il seguente elemento Identity per riflettere
l'identità con cui viene eseguito il servizio distribuito. Se rimosso, WCF dedurrà automaticamente un'identità
appropriata.
-->
<identity>
<dns value="localhost"/>
</identity>
</endpoint>
<!-- Metadata Endpoints -->
<!-- L'endpoint di scambio metadati viene utilizzato dal servizio per offrire una migliore visualizzazione ai client. -->
<!-- L'endpoint non utilizza un'associazione protetta e deve essere protetto o rimosso prima della distribuzione -->
<endpoint address="mex" binding="mexHttpBinding" contract="IMetadataExchange"/>
</service>
</services>
<bindings>
<basicHttpBinding>
<binding name="MessageSizeBasic" maxBufferSize="2147483647" maxReceivedMessageSize="2147483647">
<readerQuotas maxDepth="32" maxStringContentLength="2147483647" maxArrayLength="16348" maxBytesPerRead="4096" maxNameTableCharCount="16384"/>
</binding>
</basicHttpBinding>
<webHttpBinding>
<binding name="MessageSizeWeb" maxBufferSize="2147483647" maxReceivedMessageSize="2147483647"/>
</webHttpBinding>
<wsHttpBinding>
<!--<binding name="WSHttpBinding_IDataLayer" transactionFlow="true" maxReceivedMessageSize="2147483647">
<readerQuotas maxDepth="32" maxStringContentLength="2147483647"
maxArrayLength="16348" maxBytesPerRead="4096" maxNameTableCharCount="16384" />
</binding>-->
<binding name="WSHttpBinding_IDataLayer" transactionFlow="true" maxBufferPoolSize="2147483647" maxReceivedMessageSize="2147483647" messageEncoding="Text"
openTimeout="00:01:00"
closeTimeout="00:01:00"
sendTimeout="00:01:00"
receiveTimeout="00:01:00">
<readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647" maxArrayLength="2147483647" maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647"/>

<!--<security mode="Transport">
<transport clientCredentialType="None"/>
<message clientCredentialType="UserName" />
</security>-->

<!--<security mode="Transport">
<message clientCredentialType="UserName"
negotiateServiceCredential="true" />
</security>-->

<security mode="Transport">
<transport clientCredentialType="None"/>
</security>

</binding>
</wsHttpBinding>
</bindings>
<behaviors>
<serviceBehaviors>
<behavior name="WcfBunnyManagerBehavior">
<!-- Per evitare la diffusione di informazioni sui metadati,
impostare i valori seguenti su false prima della distribuzione -->
<serviceMetadata httpGetEnabled="true" httpsGetEnabled="true"/>
<!-- Per ricevere i dettagli sull'eccezione per scopi di debug in caso di guasti,
impostare il valore riportato sotto su true. Impostarlo su false prima della diffusione
per evitare di diffondere informazioni sull'eccezione -->
<serviceDebug includeExceptionDetailInFaults="True"/>
</behavior>
</serviceBehaviors>
</behaviors>
</system.serviceModel>
<system.net>
<connectionManagement>
<add maxconnection="200" address="*"/>
</connectionManagement>
</system.net>




App config su applicazioe desktopo in wcf:

<system.serviceModel>
<!--<bindings>
<basicHttpBinding>
<binding name="AccessoDbSoap" />
</basicHttpBinding>
</bindings>-->

<bindings>
<basicHttpBinding>
<binding name="wsComuneSoap">
<security mode="Transport" />
</binding>
<binding name="wsSistemaSoap">
<security mode="Transport" />
</binding>
<binding name="wsFunzioniApplicazioneSoap">
<security mode="Transport" />
</binding>
<binding name="BasicHttpBinding_IDataLayer" maxReceivedMessageSize="2147483647"/>
</basicHttpBinding>
<wsHttpBinding>
<binding name="WSHttpBinding_IDataLayer" transactionFlow="true" maxBufferPoolSize="2147483647" maxReceivedMessageSize="2147483647" messageEncoding="Text" sendTimeout="00:01:00">
<readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647" maxArrayLength="2147483647" maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647"/>

<security mode="Transport">
<transport clientCredentialType="None"/>
</security>

</binding>
</wsHttpBinding>
</bindings>

<client>
<endpoint address="https://www.sitoweb.com/ServiziWcf/wsComune.asmx" binding="basicHttpBinding" bindingConfiguration="wsComuneSoap" contract="ServicewsComune.wsComuneSoap" name="wsComuneSoap"/>
<endpoint address="https://www.sitoweb.com/ServiziWcf/wsSistema.asmx" binding="basicHttpBinding" bindingConfiguration="wsSistemaSoap" contract="ServicewsSistema.wsSistemaSoap" name="wsSistemaSoap"/>
<endpoint address="https://www.sitoweb.com/ServiziWcf/wsFunzioniApplicazione.asmx" binding="basicHttpBinding" bindingConfiguration="wsFunzioniApplicazioneSoap" contract="ServicewsFunzioniApplicazione.wsFunzioniApplicazioneSoap" name="wsFunzioniApplicazioneSoap"/>
<endpoint address="https://www.sitoweb.com/ServiziWcf/DataLayer.svc" binding="wsHttpBinding" bindingConfiguration="WSHttpBinding_IDataLayer" contract="DataLayerWcfRef.IDataLayer" name="WSHttpBinding_IDataLayer">

<!--<endpoint address="https://localhost:44392/ServiziWcf/wsComune.asmx" binding="basicHttpBinding" bindingConfiguration="wsComuneSoap" contract="ServicewsComune.wsComuneSoap" name="wsComuneSoap"/>
<endpoint address="https://localhost:44392/ServiziWcf/wsSistema.asmx" binding="basicHttpBinding" bindingConfiguration="wsSistemaSoap" contract="ServicewsSistema.wsSistemaSoap" name="wsSistemaSoap"/>
<endpoint address="https://localhost:44392/ServiziWcf/wsFunzioniApplicazione.asmx" binding="basicHttpBinding" bindingConfiguration="wsFunzioniApplicazioneSoap" contract="ServicewsFunzioniApplicazione.wsFunzioniApplicazioneSoap" name="wsFunzioniApplicazioneSoap"/>
<endpoint address="https://localhost:44392/ServiziWcf/DataLayer.svc" binding="wsHttpBinding" bindingConfiguration="WSHttpBinding_IDataLayer" contract="DataLayerWcfRef.IDataLayer" name="WSHttpBinding_IDataLayer">-->

<identity>
<dns value="localhost"/>
</identity>
</endpoint>
</client>
</system.serviceModel>
<system.net>
<connectionManagement>
<add maxconnection="200" address="*"/>
</connectionManagement>
</system.net>

Torna al forum | Feed RSS

ASPItalia.com non è responsabile per il contenuto dei messaggi presenti su questo servizio, non avendo nessun controllo sui messaggi postati nei propri forum, che rappresentano l'espressione del pensiero degli autori.