5 messaggi dal 25 giugno 2002
Ciao a tutti, questa è la prima volta che scrivo..
spero che ci sia qualcuno che mi possa rispondere, ho questo problema:
- ho sviluppato una pagina asp che mi permette di richiedere die dati ad un altro server ed ho utilizzato il componente INET di MSINET.OCX.
il codice è del tipo:

<%
set objInet = CreateObject("InetCtls.Inet")
objInet.requestTimeout = 20

objInet.url = "http://aaaaa.it/pagina.html"
strHTML = objInet.openURL
if strHTML = "" then
strHTML = "<No Data Available>"
end if

strHTML = mid(strHTML, instr(strHTML, " dati") + 73)
strHTML = mid(strHTML, 1, instr(strHTML, "C)") + 1)
Response.Write strHTML
Set objInet = Nothing
%>

se eseguo la pagina su una macchina con VB installato tutto ok, mentre se la eseguo su un server NT che ha sotto c:\winnt\system32\msinet.ocx non funziona, mi dà error '80040112' quando fà la create object , penso che sia qualcosa legato alle licenze, o qualche cosa del genere!!!!
sapete aiutarmi???
Grazie in anticipo!!!

Non penso che riguardi le license, bensì i permessi di creazione dell'oggetto. Le soluzioni sono 2:

La prima quella più giusta:
Carica DCOMCNFG (che sotto NT dovrebbe essere MTS ma non ne sono sicuro) e dai i permessi anche all'utente Internet per la creazione di quel controllo

La seconda (quella di test..)
Metti administrator come utente internet sotto IIS

Ciao

Andrea Palmatè
<b>Community Manager di http://www.aspitalia.com</b>

--
Andrea Palmatè
5 messaggi dal 25 giugno 2002
Grazie Andrea per avermi risposto, ma cosa intendi dire con
CARICA Dcomcnfg? Io ho aperto MTS ed ho cercato di fare un nuovo Package dicendo che doveva girare con utente Adminstrator, ma poi non riesco ad aggiungere come NEW COMPONENT un OCX, o meglio riesco a selezionarlo ma MTS non rileva nessun componente su file e quindi non mi fà andare avanti!!

Scusa forze non ho ben capito cosa tu volevi dire!!!
Potresti essere più esauriente???
Grazie!!

Un OCX non puo' essere aggiunto a MTS perchè è out of process. Prova la seconda soluzione e vedi se va.. poi vediamo come fare

Andrea Palmatè
<b>Community Manager di http://www.aspitalia.com</b>

--
Andrea Palmatè
5 messaggi dal 25 giugno 2002
Ho fatto come dici tu ma non è cambiato nulla!!!
Non so più cosa fare :-(
aiuto!!!!!!!!!!!!!!!!!


Senti una cosa, ma a te serve recuperare una pagina HTML? Perchè se è così allora puoi utilizzare MSXMLHTTP che è molto più efficiente.

Andrea Palmatè
<b>Community Manager di http://www.aspitalia.com</b>

--
Andrea Palmatè
53 messaggi dal 01 febbraio 2017
In genere gli OCX vanno registrati ... prova con REGSVR32 lanciato come amministratore, vedi se va a buon fine e poi riprova il tuo PGM.
Gino.

Torna al forum | Feed RSS

ASPItalia.com non è responsabile per il contenuto dei messaggi presenti su questo servizio, non avendo nessun controllo sui messaggi postati nei propri forum, che rappresentano l'espressione del pensiero degli autori.